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Agenda

• Basics of Digital Music

• Audio File Formats and Standards

• Building Your Music Collection

• MediaMonkey Tour
– Organizing Your Music Library

– MediaMonkey Settings, Skins and Views

– Ripping Music CDs

– Adding Files to the Library

– Editing File Tag Information

– Creating Playlists

– Downloading Music to Your Mobile Device or Flash Drive

– Internet Radio

– Video DVDS and Files

• Streaming Music Services

• Useful Web Links for More Information
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Basics of Digital Music

• Music is represented as a stream of numbers.
– Measurements of recorded electrical voltage level at an instant.

– Generally, use 16 bits (2 bytes) per measurement (sample).

– For stereo, two streams – one for each channel (left / right).

– Standard audio CD sample rate is 44,100 times per second.

– Can later convert the stream of numbers back to voltages.

• Number stream may be saved in various ways
– On an audio CD.

– In a music file on a PC hard disk (.WAV, .MP3, .FLAC or .AAC)

– Music files may be compressed in various ways or left uncompressed.

• Let’s look at a .MP3 file with Audacity Music Editor
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Audio File Formats (1)

• Microsoft WAVE  (.WAV)
– 44,100 samples/sec, stereo, 16-bit samples each channel.

– Each 16-bit value can range from -32768 to + 32767.

– Uncompressed, consumes about 10.6 MBytes per minute of sound

(44,100 * 2 * 2 * 60).

– True audio CD Quality (same specs).

• Motion Picture Experts Group 1 - Audio Layer 3 (.MP3)
– Compressed size varies based on sample rate.

– .MP3 is “lossy” – removes very high and low frequencies.

– 256 Kbits/sec (Music store quality), 64 Kbits/sec (FM quality).

– At 256 Kbits/sec, uses about 2 MB per minute of sound (20% of .WAV).

– Little point in going higher than 256 Kbits/sec for MP3.
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Audio File Formats (2)

• Microsoft Windows Media Audio (.WMA)
– Compressed, size varies based on sample rate.

– Supports Digital Rights Management standards.

– MS claims files about half the size of .MP3 files.

(My experiments didn’t confirm that).

• Apple Advanced Code (.AAC)
– Compressed, size varies based on sample rate.

– Supports Digital Rights Management standards.

– Proprietary to Apple.

• Other Formats:
– Free-Lossless (.FLAC), Ogg-Vorbis (.ogg)

• More Information
– http://ekei.com/audio

http://ekei.com/audio
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Building Your Music Collection

• Convert your own music CD collection to music files.
– Use MediaMonkey, iTunes or any of the many other popular CD “rippers”.

• Buy “used” CDs (save about 50%) to rip.

• Borrow music CDs to rip?
– From friends, public library.

• Use the Library’s Freegal music service (6 free songs / week)

• Buy digital music on-line (unlocked MP3 files).
– $.99 per song, $9.99 per “album” (sometimes less, sometimes more).

– Amazon.com and iTunes.com are now the biggest music stores.

• Record Internet streaming audio
– Use a stream recoding tool like Total Recorder.

– Have to split and tag the recorded steam into individual .mp3 files.

• Convert your old analog audio tapes and LPs to music files.
– Need a “line-in” recording tool (e.g. Spin It Again or GoldWave).

– After recording, need to separate and “clean-up” the recorded sound.
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Organizing Your Music Library

• Physical Placement of your music files.
– Folder and file hierarchy important.

– Best is Artist > Album > Song name.

– Default location is your personal “My Music” or “Music” folder.

– If have two hard drives, consider placing on the non-boot drive.

• Use MediaMonkey to index your music files into a Library.

• Set up descriptive “tags” in your music files
– Artist name, song name, album name, genre, date, album artist, composer

– Tedious work.  But, once done, these are recognized by all players and music 
organizer programs.

• Adjust physical file names based on tag values.
– Some Media Manager programs support this.
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MediaMonkey 5 Media Manager

MediaMonkey Main  Screen
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MediaMonkey 5 Media Manager

• Where to get it
– www.mediamonkey.com

– Standard edition is free, Gold edition $24.95, Lifetime Gold edition $$49.95

– Developed by Ventis Media

• Comprehensive Media Manager and Player
– Music Player, Organizer, Tagger, CD Ripper

– Video Player

– DVD, Blu-ray Player

– Playlists – Create, export, burn to audio or MP3 CD

– Download media to your Android or iOS devices

– Media sharing on your in-house LAN

– Internet Radio

– Podcasts

– File format converter

• Highly Configurable Look and Feel
– Skins

– Views

http://www.mediamonkey.com/
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Key MediaMonkey Settings

• Most Settings Found in Tools > Options menu
– Let’s browse

• Many Settings Also in the View Menu
– Let’s browse

• Some Settings Offered When a Tool Function is Invoked
– Tools > Rip Audio CD

– Tools > Convert Format
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Setting Up the Screen

• Open the View Menu
– Checkboxes for various panels

– Link to the Layout section of Settings

– Checkbox for Visualization (while playing songs)

– Checkbox for Party Mode and its Settings

(Disables some menu functions)

– Skin selector (4 choices built-in)

– Mode selector (Desktop or Tablet)

– Main panel view selector (4 choices)

I prefer the List view

– Previous lets you go back to a prior View

• Choosing Column Headings
– Right click the title bar

– Pick “Choose Columns / Sort”

– A column selector dialog will appear
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CD Ripping

• Ripping (Definition)
– Copying contents of an Audio CD to your hard disk.

– Digital audio data is converted to: .WAV, .MP3., .WMA, .AAC, .FLAC

– Often audio album, artist and track information looked up in an

Internet CD Database (CDDB). Used to tag the ripped files.

– Legal, fair personal use of copyrighted material you own.

• Many CD rippers available (shareware, freeware, jukeboxes).
– Can search for “CD Rippers”

– MediaMonkey or iTunes are very easy to use for ripping.

– Easy – Place CD in your CD drive and “rip away”.

– Ripped files can go in any folder – usually the default is “My Music”.
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Demo - Ripping An Audio CD

• We’ll use MediaMonkey, but iTunes is also good.

• Insert the audio CD to be ripped.

• In MediaMonkey, click the CD/DVD drive in the left-hand pane.

Then go to Tools > Rip Audio CD

• A “Rip CD” dialog will open listing the tracks on the CD and 

offering various settings for ripping.
– Choose the MP3 encoder in the drop down.

– The “standard” version only offers “VBR ~192 kbps - Very High Quality”

sample rate. The Gold version offers more choices.

– Click the Configure button to choose the target folder and file name layout for 

the ripped files.

– Choose “Standard read” for the Rip type.

– Check “Eject CD after ripping”.

– Check “On the fly encoding”.

– Uncheck any tracks you don’t want to rip.

– Click OK to start the rip. It should run 3 to 5 minutes, based on track count.
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Adding Files to the Library

• We’ll use MediaMonkey; iTunes or Media Player also 

work.

• Demo – Adding Files to a MediaMonkey Library
– Go to File > Add /  Rescan files to the Library.

– A dialog will appear showing all the current folders being monitored.

– Click “Add Location” and browse to the folder containing the new 

tracks and check it. Repeat for each folder of tracks to be added.

– When finished, click “SCAN NOW ”.

– MediaMonkey will scan (or rescan) the entire collection of folders,  

index all the music files and build / update library entries.

– The Library is indexed by Genre, Artist, Album and Song Title.
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Editing Music File Tags

• We’ll use MediaMonkey; iTunes or Media Player also work.

• Demo – Editing the tag information for a set of MP3 files.
– In the left-hand pane, click “Music” (or you can select a playlist)

– Select one or a set of files by clicking, shift clicking, right clicking.

– Right click on the file or set and then select “Properties”.

– A multi-tabbed File Properties dialog will appear. The Basic tab is 

normally the only one you would use.

– If editing a set of files, only fields that would apply to the entire set are 

active.

– Make changes as desired and then click OK to save the changes.

– The tags in the selected file(s) are updated and the Library entries are 

updated.
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Creating and Updating Playlists

• A Playlist is an ordered list of tracks that can be 

played, burned or downloaded. Each item in the 

playlist is a link to the actual file.

• To start a new Playlist:

– Go to Edit > New Playlist or right-click in the Playlist 

area and choose New Playlist.

– Enter the name of the Playlist at the top of the list.

• To add tracks to a Playlist:

– Drag and drop files from the Music list to the Playlist.

– Right click a track and choose Send to and then select 

the desired Playlist name.

• To remove tracks from a Playlist:

– Select one or more tracks in the Playlist.

– Right-click and select Remove; then indicate “Remove 

from Playlist only”.

• To reorder tracks in a Playlist:

– Click on a track and drag it up or down in the list.
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Demo – Downloading a PlayList

• Demo – Download a Play List to a Flash Drive
– Plug in your flash drive to a USB port.

– Select or create a Play List (see previous slide).

– Sort or order the playlist to suit.

– Right click the Playlist in the lefthand pane. Hover over “Send To”

– Choose the flash drive from the list of Send to targets.

– MediaMonkey will copy the songs in the Playlist to the flash drive.

– You can ow plug the flash drive into your car stereo or take it to a party.

• Demo - Download a Play List to an Android Hand-held.
– Plug in your Android device to a USB port.

– Select USB “File” mode on your phone. Windows will “mount” your phone in 

File  Explorer.

– Follow the steps above for copying to a flash drive but select your phone as 

the target of the “Send To”.

– Or … copy the music files to a micro-SD card and plug it in to your device.
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Demo – Streaming Internet Radio

• MediaMonkey supports streaming of Internet radio stations

• Thousands of streams are accessible – most for free

• In the lefthand pane, click to open the Web area
– Choices are Amazon, iHeart.com, Last.fm and Radio

– Under  Radio are: Internet Radio, Radio Cast, Shoutcast, Radio Forest

– You can explore to yor heart’s content.

• Demo – Exploring Internet streaming radio
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Playing and Managing Videos

• MediaMonkey can play video DVDs
– Insert the DVD into your PC’s DVD drive.

– MediaMonkey will recognize the DVD and offer to play it.

• MediaMonkey can play video files added to your 

library
– Click to open the Video section in the left-hand pane.

– Click the “All videos” item to display all videos in your

library.

– Double-click an item to play it.

– Can filter the displayed list by various criteria.

– Can right click and select Properties to edit tags.

– Can right click and select Remove to remove from the

library and optionally from the computer.
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Streaming Music Services (1)

• https://www.consumerreports.org/streaming-music-services/best-

music-streaming-service-for-you/

• Amazon Prime Music (Free with a Prime subscription) or 

Amazon Music Unlimited ($8 monthly)
– https://www.amazon.com/music

• Apple Music ($10 / month)
– https://www.apple.com/apple-music

• Napster ($5 and $10 monthly)
– http://us.napster.com

• Pandora (Free, $5, $10 monthly)
– http://www.Pandora.com

http://www.pandora.com/
https://www.amazon.com/music
https://www.apple.com/apple-music
http://us.napster.com/
http://www.pandora.com/
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Streaming Music Services (2)

• Spotify (free & $10 monthly)
– https://www.spotify.com/us/

• YouTube Music (free & $10 per month)
– https://www.youtube.com/musicpremium

• Shoutcast (Internet Radio stations)
– Available via iTunes & other Music Library programs

• Sirius XM - Satellite radio ($17 / month)

• Music channels on Cox, DirecTV & Dish (Bundled)

https://www.spotify.com/us/
https://www.youtube.com/musicpremium
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Other Useful Web Links

• https://electronics.howstuffworks.com/cd.htm

• https://www.audacityteam.org/download/

• https://www.goldwave.com/goldwave.php

• http://www.itunes.com

• http://www.videolan.org

• http://www.microsoft.com

• http://www.ashampoo.com

• https://acoustica.com/products/spin-it-again

https://electronics.howstuffworks.com/cd.htm
https://www.audacityteam.org/download/
https://www.goldwave.com/goldwave.php
http://www.itunes.com/
http://www.videolan.org/
http://www.microsoft.com/
http://www.ashampoo.com/
https://acoustica.com/products/spin-it-again

